Quick Tip: Re-Enabling Disabled Designer Plugins

May 19, 2015 12:58 PM

Tags: designer

Recently, I had a case where my installed Designer plugins stopped appearing, immediately made obvious by the libraries disappearing from XPages applications and Designer listing hundreds of class-not-found errors. At first, I figured that the local plugins had been deleted, but trying to install from update sites curtly informed me that they contained nothing new for me.

It turned out that my local plugins had been somehow marked disabled by Designer. The fix for this was to go to File → Application → Application Management (you may have to launch Designer to see this option) and to enable them there. Crucially, the disabled plugins didn't show up until I clicked the "Show Disabled Features" button (forgive the grossly-outdated Notes version on this client machine):

Once I did that, the second category of plugins (in the data folder) listed everything I expected, and I was able to re-enable them there. One hitch to this process is that it requires sticking to the dependency order, so some plugins may refuse to be enabled until you enable others (commonly, any that depend on the Extension Library).

I'm not sure what specifically caused all these plugins to take a nap, but I suspect it's related to a recent Interim Fix or the Java update, since it happened around when I installed those, and I've heard others report the same behavior.

Commenter Photo

Lars Berntrop-Bos - May 21, 2015 6:41 AM

Thanks!

Realy weird: not only found a custom installed plugin disabled, but also a system one:

Core Expeditor Platform Feature Patch 9.0.1.20141217-0915

installed in framework\rcp\eclipse.  Seems pretty core system to me.  Completely baffled why this would be disabled.  Might solve the recent client crashes!

New Comment